Website sử dụng mã nguồn mở Drupal dính cảnh báo bảo mật

Chia sẻ nếu hữu ích

Công ty An ninh mạng CyStack vừa cho biết, Drupal-một nền tảng mã nguồn mở được dùng rộng rãi trên thế giới và cũng được rất nhiều website tại Việt Nam sử dụng, hiện đang tồn tại lỗ hổng bảo mật nghiêm trọng cho phép hacker có thể chiếm quyền điều khiển máy chủ.

Trong thông tin phát ra chiều nay, ngày 21/4/2018, Công ty Công ty An ninh mạng CyStack cho biết, mới đây, một lỗ hổng nghiêm trọng với tên gọi Drupalgeddon2 (mã CVE-2018-7600) đã được phát hiện trong các phiên bản từ 6 đến 8 của nền tảng Drupal. Lỗ hổng nghiêm trọng này cho phép hacker có thể chiếm toàn quyền kiểm soát website.

Cụ thể, theo phân tích của các chuyên gia, lỗ hổng nằm ở tính năng Form API trong core của Drupal, hacker có thể chèn và thực thi các đoạn mã tùy ý mà không cần xác thực thông qua các biến (param) trên đường dẫn của website.

Đáng chú ý, thông tin từ Công ty CyStack cũng cho hay, sau khi kiểm tra, chuyên gia CyStack đã phát hiện trong tổng số khoảng 1.000 website Drupal tại Việt Nam được quét, có đến hơn 500 website vẫn đang sử dụng phiên bản Drupal có lỗ hổng và có khả năng bị hacker khai thác, trong đó có nhiều website quan trọng của các ngân hàng, tập đoàn công nghệ, các trường đại học, và cả các website cơ quan nhà nước…

“Đây chưa phải con số cuối cùng bởi số lượng website Drupal tại Việt Nam khá lớn và Drupalgeddon2 là lỗ hổng cực kỳ nghiêm trọng, cho phép chiếm quyền điều khiển website, với cách thức khai thác rất đơn giản”, đại diện CyStack nhận định.

Cũng trong thông tin mới phát ra, cùng với việc cho biết hiện tính năng năng phát hiện lỗ hổng Drupalgeddon2 cho website đã được CyStack nghiên cứu, tích hợp trong nền tảng bảo mật CyStack Platform, Công ty An ninh mạng CyStack cũng thông báo các quản trị viên có thể đăng ký và quét lỗ hổng cũng như mã độc của website miễn phí tại: https://app.cystack.net.

Bên cạnh đó, các chuyên gia CyStack cũng hướng dẫn các quản trị viên cách thức khác phục. Theo CyStack, thời điểm hiện tại, Drupal đã đưa ra bản vá và bản cập nhật mới cho lỗ hổng. Cụ thể, nếu quản trị viên đang sử dụng phiên bản Drupal 7.x, hãy nâng cấp lên phiên bản Drupal 7.58; nếu đang sử dụng phiên bản 8.5.x, hãy nâng cấp lên phiên bản Drupal 8.5.1; nếu bạn đang sử dụng phiên bản 8.3.x, hãy nâng cấp lên phiên bản Drupal 8.3.9 hoặc sử dụng bản vá của Drupal; còn nếu đang sử dụng phiên bản 8.4.x, hãy nâng cấp lên phiên bản Drupal 8.4.6 hoặc sử dụng bản vá của Drupal.

Trong trường hợp không thể cài đặt các phiên bản mới, các quản trị có thể cập nhật bản vá thủ công tại trang web có địa chỉ: https://www.drupal.org/sa-core-2018-002 hoặc liên hệ với CyStack Security để được hỗ trợ.

Đối với các website đã bị tin tặc tấn công chiếm quyền điều khiển, lây nhiễm mã độc, các quản trị viên có thể sử dụng tính năng Responding (Malware Scanning) trong CyStack Platform để khôi phục website của mình.

Nguồn: ICTNews

Chia sẻ nếu hữu ích

Về Khôi Nguyễn

Technical Lead tại Solis Lab. Locale Manager tại WordPress Việt Nam. Chief Editor tại Code Tốt và Yêu Host.

Xem tất cả bài viết của Khôi Nguyễn →

One Comment on “Website sử dụng mã nguồn mở Drupal dính cảnh báo bảo mật”

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

twenty − 15 =